Problem Description给出一段连续的内存,假设它的值是x,请输出x*16+7.Input多组测试数据,每组数据一行,仅由0和1组成.每行长度不超过60,并且不含前导0.Output对每组数据输出一行,表示x*16+7.注意:输出

来源:学生作业帮助网 编辑:作业帮 时间:2024/04/20 19:04:23
Problem Description给出一段连续的内存,假设它的值是x,请输出x*16+7.Input多组测试数据,每组数据一行,仅由0和1组成.每行长度不超过60,并且不含前导0.Output对每组数据输出一行,表示x*16+7.注意:输出

Problem Description给出一段连续的内存,假设它的值是x,请输出x*16+7.Input多组测试数据,每组数据一行,仅由0和1组成.每行长度不超过60,并且不含前导0.Output对每组数据输出一行,表示x*16+7.注意:输出
Problem Description
给出一段连续的内存,假设它的值是x,请输出x*16+7.
Input
多组测试数据,每组数据一行,仅由0和1组成.
每行长度不超过60,并且不含前导0.
Output
对每组数据输出一行,表示x*16+7.
注意:输出必须是转化为二进制后的结果.
Sample Input
10
Sample Output
100111
Hint
(10)2=2,2*16+7=39,(39)2=100111.

Problem Description给出一段连续的内存,假设它的值是x,请输出x*16+7.Input多组测试数据,每组数据一行,仅由0和1组成.每行长度不超过60,并且不含前导0.Output对每组数据输出一行,表示x*16+7.注意:输出
#include<stdio.h>
#include<string.h>
int main()
{
char str[100];
while(scanf("%s",str)!=EOF){
printf("%s",str);
printf("0111\n");
}
return 0;
}

思路:x*16等于x*2^4,相当于x左移4位,又x加7,及x后面加0111,输出即可.

杭电上的题目Problem Description输入n(n description how can we treat the gas problem of infant when we use lactogen.I mean theDetailed description of the problem and help respondents provide accurate answers to Formal analogue是什么意思rmal analogue Analogy Can you find a problem analogous to your problem and solve that?MapHeuristic Informal Description Formal analogue Analogy Can you find a problem analogous to your problem and Mapsolve that?Generaliz 杭电ACM 2019 数列有序问题 输出错误Problem Description有n(n<=100)个整数,已经按照从小到大顺序排列好,现在另外给一个整数x,请将该数插入到序列中,并使新的序列仍然有序. Input输入数据包含多 杭电ACM 2019 数列有序 输出错误Problem Description有n(n<=100)个整数,已经按照从小到大顺序排列好,现在另外给一个整数x,请将该数插入到序列中,并使新的序列仍然有序. Input输入数据包含多个测 problem 英语翻译Description? description page description是什么意思? DESCRIPTION是什么意思 description是什么意思? Item Description 好听的英文名字l开头的 我是射手座女孩Detailed description of the problem and help respondents provide accurate answers to write a brief description of three social problems in the city,and then write 2 causes and 2 effects of that social problem 湖南大学acm10007题Prime Test Time Limit: 5000ms, Special Time Limit:10000ms, Memory Limit:65536KB Total submit users: 463, Accepted users: 65 Problem 10007 : No special judgement Problem description Given a big integer number, you are requir 能被3整除的数 Problem Description 找出数组a中能被 3整除的数 要求用数组完...能被3整除的数 Problem Description找出数组a中能被 3整除的数要求用数组完成. Input输入整数N,代表N组数据.接下来的N行 description和description of的区别